Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 26, 2026 - 11:00 IST
Scheduled
Dear Valued Customer,
We will be carrying out an urgent, unplanned maintenance activity on our reporting database infrastructure in order to improve database performance and platform stability. This activity will help us to:
1. Improve database performance through configuration and optimization changes 2. Enhance overall platform stability and responsiveness 3. Reduce recurring operational issues 4. Provide a robust foundation for future platform enhancements and feature development
What this activity involves: 1. Maintenance of our database infrastructure for better performance 2. Deployment of compatibility and configuration changes across affected services 3. End-to-end validation and functional testing
Impacted Products: The following products may experience intermittent interruption only for database-dependent functionalities:
1. Email API platform 2. WhatsApp API platform 3. RCS API platform 4. SMS API platform
Maintenance Window: 📅 Date: Sunday, 26th July 2026 🕐 Time: 11:00 AM IST to 12:00 PM IST Planned Downtime: Up to 60 minutes
What will be impacted: During this maintenance window, services that depend on database operations may be unavailable or experience temporary downtime, including: 1. Client Panels (Email, WhatsApp, RCS, SMS) 2. Reporting 3. Reporting APIs that rely on Database 4. Any other DB-dependent backend services
What will NOT be impacted: The following services will continue to operate as normal and will not be affected during this maintenance window: 1. SMTP or API based Mail/message Injection 2. Webhook Services 3. RCS Template list
Note: The processing of emails via Email API/SMTP and messages via SMS, Whatsapp & RCS , mail delivery, API requests and webhook delivery will continue without interruption.
Need help? If you face any issues or have questions during or after this window, you can reach us via Live Chat on the portal or email us at help@netcorecloud.com
We appreciate your understanding as we carry out this upgrade to continue improving the reliability and performance of our platform.
Warm regards, CPaaS Support Team , Netcore
Posted Jul 24, 2026 - 19:30 IST
This scheduled maintenance affected: APAC (CPaaS - Email, CPaaS - Whatsapp), US (CPaaS - Email, CPaaS - Whatsapp), and India (CPaaS - Email, CPaaS - SMS, CPaaS - Whatsapp, CPaaS - RCS).